New Status Dashboard is now live.
Incident Report for Docman
Monitoring
We have launched a new status dashboard.
This has added functionality and abilities. You can also register for email and text/sms alerts.
Resolved issues remain visible for later review, this was not possible on the old system.

It can be accessed at https://www.docman.com/status/ and https://advancedhealthandcare.statusdashboard.com/
Posted Mar 20, 2024 - 12:08 GMT