Docman Connect - Password Recovery issue
Incident Report for Docman
Resolved
This issue is now resolved.
Posted Sep 17, 2021 - 11:01 BST
Investigating
We are currently investigating an issue where when a user tries to recover the NHS Mail Password they are receiving a 504 Error.
Posted Sep 17, 2021 - 09:06 BST
This incident affected: Docman Advanced (Docman Connect).